RIP: RIP Stands for Routing Information Protocol. RIP is a Distance Vector Protocol. It Select best path be Hop Count.
Characteristics of RIP:
Configuring RIP: RIP and RIPv2.
Characteristics of RIP:
- RIP is a Distance Vector Protocol.
- RIP is a classfull and not support VLSM.
- RIP sent periodic update after 30 minutes, its Hold down time is 180 seconds, Invalid Time is 180 seconds and Flush timer is 240 seconds.
- During sent updates to in neighbors, RIP sent entire routing table.
- RIP broadcast its update in 255.255.255.255
- RIP use maximum 16 hop count. After 15 hop this route will be unreachable.
- RIP Administrative Distance is 120.
- RIP use UDP port 520.
- RIPv2 is a Distance Vector Protocol.
- RIPv2 is a classfless and support VLSM.
- RIPv2 sent periodic update after 30 minutes, its Hold down time is 180 seconds, Invalid Time is 180 seconds and Flush timer is 240 seconds.
- RIPv2 sent entire routing table during update sent.
- RIPv2 multicast its update in 224.0.0.9
- RIPv2 use maximum 16 hop count. After 15 hop this route will be unreachable.
- RIPv2 Administrative Distance is 120.
- RIPv2 support authentication (Encrypted and clear text).
Configuring RIP: RIP and RIPv2.
RIP and RIPv2 Network Topology
Configure R1:
R1#
R1#configure
terminal
R1(config)#interface
FastEthernet0/1
R1(config-if)#ip
address 172.16.1.1 255.255.255.0
R1(config-if)#no
shutdown
R1(config-if)#exit
R1(config)#interface
FastEthernet0/0
R1(config-if)#ip
address 172.16.12.1 255.255.255.0
R1(config-if)#no
shutdown
R1(config)#router
rip
Router(config-router)#network
172.16.0.0Configure R2:
R2#
R2#configure
terminal
R2(config)#interface
FastEthernet0/0
R2(config-if)#no
shutdown
R2(config-if)#ip
address 172.16.12.2 255.255.255.0
R2(config-if)#exit
R2(config)#interface
FastEthernet0/1
R2(config-if)#no
shutdown
R2(config-if)#ip
address 172.16.23.2 255.255.255.0
R2(config)#router
rip
R2(config-router)#version
2
R2(config-router)#network
172.16.0.0
R2(config-router)#no auto-summary
Configure R3:
R3#configure
terminal
R3(config)#interface
FastEthernet0/0
R3(config-if)#
ip address 172.16.34.3 255.255.255.0
R3(config-if)#no
shutdown
R3(config-if)#exit
R3(config)#interface
FastEthernet0/1
R3(config-if)#
ip address 172.16.23.3 255.255.255.0
R3(config-if)#no
shutdown
R3(config)#router
rip
R3(config-router)#version
2
R3(config-router)#network
172.16.0.0
R3(config-router)#no auto-summary
Configure R4:
R4#configure
terminal
R4(config)#interface
FastEthernet0/0
R4(config-if)#ip
address 172.16.34.4 255.255.255.0
R4(config-if)#no
shutdown
R4(config-if)#exit
R4(config)#router
rip
R4(config-router)#version
2
R4(config-router)#network
172.16.0.0
R4(config-router)#no auto-summary
Routing Table R1, R2, R3 and R4:
R1#show ip route
172.16.0.0/24 is subnetted, 4 subnets
R 172.16.34.0 [120/2] via 172.16.12.2, 00:00:16, FastEthernet0/0
R 172.16.23.0 [120/1] via 172.16.12.2, 00:00:16, FastEthernet0/0
C 172.16.12.0 is directly connected, FastEthernet0/0
C 172.16.1.0 is directly connected, FastEthernet0/1
R2#show ip route
172.16.0.0/24 is subnetted, 3 subnets
R 172.16.34.0 [120/1] via 172.16.23.3, 00:00:23, FastEthernet0/1
C 172.16.23.0 is directly connected, FastEthernet0/1
C 172.16.12.0 is directly connected, FastEthernet0/0
R3#show ip route
172.16.0.0/24 is subnetted, 3 subnets
C 172.16.34.0 is directly connected, FastEthernet1/0
C 172.16.23.0 is directly connected, FastEthernet0/1
R 172.16.12.0 [120/1] via 172.16.23.2, 00:00:09, FastEthernet0/1
R4#show ip route
172.16.0.0/24 is subnetted, 3 subnets
C 172.16.34.0 is directly connected, FastEthernet1/0
R 172.16.23.0 [120/1] via 172.16.34.3, 00:00:26, FastEthernet1/0
R 172.16.12.0 [120/2] via 172.16.34.3, 00:00:26, FastEthernet1/0
//Network 172.16.1.0 missing in R2, R3 and R4. Because RIPv2 sent and receive only Version 2. We need to configure Router R2 fa0/0 to Receive RIP version 1 updates.
Similarly RIP version 1 can't sent RIPv2 updates. so we need to configure Router R1 fa0/0 interface to sent RIPv2 updates.
Router R2 log:
R2#debug ip rip
R2#RIP:
sending v2 update to 224.0.0.9 via
FastEthernet0/1 (172.16.23.2)
RIP: build
update entries
172.16.12.0/24 via 0.0.0.0, metric 1, tag
0
RIP:
sending v2 update to 224.0.0.9 via
FastEthernet0/0 (172.16.12.2)
RIP: build
update entries
172.16.23.0/24 via 0.0.0.0, metric 1, tag
0
172.16.34.0/24 via 0.0.0.0, metric 2, tag
0
192.168.1.0/24 via 0.0.0.0, metric 3, tag
0
RIP: ignored v1 packet from
172.16.12.1 (illegal version)
RIP:
received v2 update from 172.16.23.3 on FastEthernet0/1
172.16.34.0/24 via 0.0.0.0 in 1 hops
192.168.1.0/24 via 0.0.0.0 in 2 hops
Router R1 Log:
R1#debug ip rip
R1#RIP: sending v1 update to 255.255.255.255 via FastEthernet0/1 (1.1.1.1)
R1#RIP: sending v1 update to 255.255.255.255 via FastEthernet0/1 (1.1.1.1)
RIP: build
update entries
network 172.16.0.0 metric 1
network 192.168.1.0 metric 4
RIP: sending v1 update to 255.255.255.255 via
FastEthernet0/0 (172.16.12.1)
RIP: build update entries
network 1.0.0.0 metric 1
RIP:
received v2 update from 172.16.12.2 on FastEthernet0/0
172.16.23.0/24 via 0.0.0.0 in 1 hops
172.16.34.0/24 via 0.0.0.0 in 2 hops
192.168.1.0/24 via 0.0.0.0 in 3 hops
Communication Between RIP and RIPv2:
Configuration:
R2(config)#interface FastEthernet0/0
R2(config)#ip
rip receive version 1
Routing table Router R2:
R2#clear ip route *
R2#show ip route
172.16.0.0/24 is subnetted, 4 subnets
R 172.16.34.0 [120/1] via 172.16.23.3, 00:00:23, FastEthernet0/1
C 172.16.23.0 is directly connected, FastEthernet0/1
C 172.16.12.0 is directly connected, FastEthernet0/0
R 172.16.1.0 [120/1] via 172.16.12.1, 00:00:01, FastEthernet0/0
Configuration:
R1(config)#interface FastEthernet0/0
R1(config)#ip rip sent version 2
// R1(config)#ip rip send version 1
// R1(config)#ip rip send version 1 2
// R1(config)#ip rip rec version 1 2
Explanation of RIP Routing table:
R2#show ip route
R 172.16.34.0 [120/1] via 172.16.23.3, 00:00:23, FastEthernet0/1
R means this is RIP Routing.
172.16.34.0 is Destination Network.
[120/1] is Administrative Distance/Metric Value.
172.16.23.3 is next hop address.
RIP Authentication and Configuration:
Configuration Clear text Authentication between R2 and R3.
//R1 and R2 not possible because RIP version 1 configured in R1 and RIP version 1 not support Authentication.
R2(config)#key chain cisco
R2(config-keychain)#key 10
R2(config-keychain-key)#key-string ccie
R2(config-keychain-key)#end
R2#conf t
Check R2 Routing table:
R2#show ip route
172.16.0.0/24 is subnetted, 3 subnets
C 172.16.23.0 is directly connected, FastEthernet0/1
C 172.16.12.0 is directly connected, FastEthernet0/0
R 172.16.1.0 [120/1] via 172.16.12.1, 00:00:13, FastEthernet0/0
//Network 172.16.34.0 is missing
R3(config)#key chain cisco
R3(config-keychain)#key 10
R3(config-keychain-key)#key-string ccie
R3(config-keychain-key)#end
R3#conf t
R3(config)#interface fastEthernet 0/1
R3(config-if)#ip rip authentication key-chain cisco
//Due to clear text authentication we can see the key-string
//*Mar 1 01:42:24.883: RIP: received packet with text authentication ccie
Now Check R2 Routing table:
R2#show ip route
172.16.0.0/24 is subnetted, 4 subnets
R 172.16.34.0 [120/1] via 172.16.23.3, 00:00:20, FastEthernet0/1C 172.16.23.0 is directly connected, FastEthernet0/1
C 172.16.12.0 is directly connected, FastEthernet0/0
R 172.16.1.0 [120/1] via 172.16.12.1, 00:00:26, FastEthernet0/0
R2#
Now Configure Encrypted Authentication between R2 and R3: key chain , key number and key string remain unchanged.
R2(config)#interface fastEthernet 0/0
R2(config-if)#no ip rip authentication key-chain cisco
R2(config-if)#ip rip authentication mode md5
R2(config-if)#ip rip authentication key-chain cisco
R2(config-if)#
R3(config)#interface fastEthernet 0/1
R3(config-if)#no ip rip authentication key-chain cisco
R3(config-if)#ip rip authentication mode md5
R3(config-if)#ip rip authentication key-chain cisco
//*Mar 1 01:42:46.487: RIP: received packet with MD5 authentication
RIP Default Timers and Configuration:
RIP has four timers Update Timers, Hold Down Timers, Invalid Timers and Flush Timers. This RIP times is possible to configure. Lest check what is default settings.
R2#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 20 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 1 2 1 2
FastEthernet0/1 2 2 cisco
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
172.16.0.0
Routing Information Sources:
Gateway Distance Last Update
172.16.23.3 120 00:00:25
172.16.12.1 120 00:00:10
Distance: (default is 120)
R2#
Configuration:
R2(config)#router rip
R2(config-router)#timers basic 20 120 120 180
R2(config)#do sh ip proto
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 20 seconds, next due in 3 seconds
Invalid after 120 seconds, hold down 120, flushed after 180
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 1 2 1 2
FastEthernet0/1 2 2 cisco
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
172.16.0.0
Routing Information Sources:
Gateway Distance Last Update
172.16.23.3 120 00:00:10
172.16.12.1 120 00:00:16
Distance: (default is 120)
R2(config)#
RIP Passive Interface Configuration:
We can avoid routing update from all interface or individual interface. So it cant be sent routing update to other interface but receive routing updates from other router.
R4(config)#router rip
R4(config-router)#passive-interface fastEthernet 1/0
or
R4(config)#router rip
R4(config-router)#passive-interface default
R4(config-router)#no passive-interface fastEthernet 1/0
R2 Routing table Before Configure Passive interface fa 1/0 in R4:
R2#show ip route
R 192.168.44.0/24 [120/2] via 172.16.23.3, 00:00:10, FastEthernet0/1
172.16.0.0/24 is subnetted, 4 subnets
R 172.16.34.0 [120/1] via 172.16.23.3, 00:00:10, FastEthernet0/1
C 172.16.23.0 is directly connected, FastEthernet0/1
C 172.16.12.0 is directly connected, FastEthernet0/0
R 172.16.1.0 [120/1] via 172.16.12.1, 00:00:12, FastEthernet0/0
R 192.168.4.0/24 [120/2] via 172.16.23.3, 00:00:10, FastEthernet0/1
//Color Routes are come from R4.
R2 Routing table after configure Passive interface fa 1/0 in R4:
R2#show ip route
172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
R 172.16.34.0/24 [120/1] via 172.16.23.3, 00:00:08, FastEthernet0/1
C 172.16.23.0/24 is directly connected, FastEthernet0/1
C 172.16.12.0/24 is directly connected, FastEthernet0/0
R 172.16.11.1/32 [120/1] via 172.16.12.1, 00:00:00, FastEthernet0/0
R 172.16.1.0/24 [120/1] via 172.16.12.1, 00:00:00, FastEthernet0/0
R2#
Distribute List in RIP
Distribute List can be Implemented only a Single Routing Domain. So lets use Distribute list in RIP.
Routing table of R1 before apply distributed list in R4:
R1#show ip route
R 192.168.44.0/24 [120/3] via 172.16.12.2, 00:00:13, FastEthernet0/0
R 192.168.43.0/24 [120/3] via 172.16.12.2, 00:00:13, FastEthernet0/0 172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
R 172.16.34.0/24 [120/2] via 172.16.12.2, 00:00:13, FastEthernet0/0
R 172.16.23.0/24 [120/1] via 172.16.12.2, 00:00:13, FastEthernet0/0
C 172.16.12.0/24 is directly connected, FastEthernet0/0
C 172.16.11.1/32 is directly connected, Loopback11
R 172.16.23.23/32 [120/3] via 172.16.12.2, 00:00:15, FastEthernet0/0
C 172.16.1.0/24 is directly connected, FastEthernet0/1
R 192.168.4.0/24 [120/3] via 172.16.12.2, 00:00:15, FastEthernet0/0R1#
R3 Routing Log before apply distributed list in R4:
*Mar 1 03:50:37.487: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/1 (172.16.23.3)
*Mar 1 03:50:37.487: RIP: build update entries
*Mar 1 03:50:37.487: 172.16.23.23/32 via 0.0.0.0, metric 2, tag 0
*Mar 1 03:50:37.491: 172.16.34.0/24 via 0.0.0.0, metric 1, tag 0
*Mar 1 03:50:37.491: 192.168.4.0/24 via 0.0.0.0, metric 2, tag 0
*Mar 1 03:50:37.491: 192.168.43.0/24 via 0.0.0.0, metric 2, tag 0*Mar 1 03:50:37.495: 192.168.44.0/24 via 0.0.0.0, metric 2, tag 0
R3#
Configuration: Now Deny 192.168.4.0 and 192.168.43.0 network from R4 by Distributed List.
R4#conf t
R4(config)#access-list 10 deny 192.168.4.0 0.0.0.255
R4(config)#access-list 10 deny 192.168.43.0 0.0.0.255
R4(config)#access-list 10 permit any
R4#conf t
R4(config)#router rip
R4(config-router)#distribute-list 10 out fastEthernet 1/0
Routing table of R1 after Distributed list applied in R4:
R1#show ip route
R 192.168.44.0/24 [120/3] via 172.16.12.2, 00:00:14, FastEthernet0/0
172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
R 172.16.34.0/24 [120/2] via 172.16.12.2, 00:00:14, FastEthernet0/0
R 172.16.23.0/24 [120/1] via 172.16.12.2, 00:00:14, FastEthernet0/0
C 172.16.12.0/24 is directly connected, FastEthernet0/0
C 172.16.11.1/32 is directly connected, Loopback11
R 172.16.23.23/32 [120/3] via 172.16.12.2, 00:00:14, FastEthernet0/0
C 172.16.1.0/24 is directly connected, FastEthernet0/1
R1#
//192.168.4.0 and 192.168.43.0 network denied by Distributed list.
R3 Log:
R3#
*Mar 1 04:34:05.114: RIP: received v2 update from 172.16.34.4 on FastEthernet1/0
*Mar 1 04:34:05.114: 172.16.23.23/32 via 0.0.0.0 in 1 hops
*Mar 1 04:34:05.114: 192.168.44.4/32 via 0.0.0.0 in 1 hops
R3#
//192.168.4.0 and 192.168.43.0 network denied by Distributed list.
Note: Will Be continued with Load Balancing, Redundant link and Redistribution.
Routing table Router R2:
R2#clear ip route *
R2#show ip route
172.16.0.0/24 is subnetted, 4 subnets
R 172.16.34.0 [120/1] via 172.16.23.3, 00:00:23, FastEthernet0/1
C 172.16.23.0 is directly connected, FastEthernet0/1
C 172.16.12.0 is directly connected, FastEthernet0/0
R 172.16.1.0 [120/1] via 172.16.12.1, 00:00:01, FastEthernet0/0
Configuration:
R1(config)#interface FastEthernet0/0
R1(config)#ip rip sent version 2
// R1(config)#ip rip send version 1
// R1(config)#ip rip send version 1 2
// R1(config)#ip rip rec version 1 2
Explanation of RIP Routing table:
R2#show ip route
R 172.16.34.0 [120/1] via 172.16.23.3, 00:00:23, FastEthernet0/1
R means this is RIP Routing.
172.16.34.0 is Destination Network.
[120/1] is Administrative Distance/Metric Value.
172.16.23.3 is next hop address.
RIP Authentication and Configuration:
Configuration Clear text Authentication between R2 and R3.
//R1 and R2 not possible because RIP version 1 configured in R1 and RIP version 1 not support Authentication.
R2(config)#key chain cisco
R2(config-keychain)#key 10
R2(config-keychain-key)#key-string ccie
R2(config-keychain-key)#end
R2#conf t
R2(config)#interface fastEthernet 0/1
R2(config-if)#ip rip authentication key-chain
//Invalid authentication causes routing updated failed in both router.
//*Mar 1 01:23:07.319:
RIP: ignored v2 packet from 172.16.23.3 (invalid authentication)
//*Mar 1 01:38:41.639: 172.16.1.0/24 via 0.0.0.0 in 16 hops (inaccessible)
Check R2 Routing table:
R2#show ip route
172.16.0.0/24 is subnetted, 3 subnets
C 172.16.23.0 is directly connected, FastEthernet0/1
C 172.16.12.0 is directly connected, FastEthernet0/0
R 172.16.1.0 [120/1] via 172.16.12.1, 00:00:13, FastEthernet0/0
//Network 172.16.34.0 is missing
R3(config)#key chain cisco
R3(config-keychain)#key 10
R3(config-keychain-key)#key-string ccie
R3(config-keychain-key)#end
R3#conf t
R3(config)#interface fastEthernet 0/1
R3(config-if)#ip rip authentication key-chain cisco
//Due to clear text authentication we can see the key-string
//*Mar 1 01:42:24.883: RIP: received packet with text authentication ccie
Now Check R2 Routing table:
R2#show ip route
172.16.0.0/24 is subnetted, 4 subnets
R 172.16.34.0 [120/1] via 172.16.23.3, 00:00:20, FastEthernet0/1C 172.16.23.0 is directly connected, FastEthernet0/1
C 172.16.12.0 is directly connected, FastEthernet0/0
R 172.16.1.0 [120/1] via 172.16.12.1, 00:00:26, FastEthernet0/0
R2#
Now Configure Encrypted Authentication between R2 and R3: key chain , key number and key string remain unchanged.
R2(config)#interface fastEthernet 0/0
R2(config-if)#no ip rip authentication key-chain cisco
R2(config-if)#ip rip authentication mode md5
R2(config-if)#ip rip authentication key-chain cisco
R2(config-if)#
R3(config)#interface fastEthernet 0/1
R3(config-if)#no ip rip authentication key-chain cisco
R3(config-if)#ip rip authentication mode md5
R3(config-if)#ip rip authentication key-chain cisco
//*Mar 1 01:42:46.487: RIP: received packet with MD5 authentication
RIP Default Timers and Configuration:
RIP has four timers Update Timers, Hold Down Timers, Invalid Timers and Flush Timers. This RIP times is possible to configure. Lest check what is default settings.
R2#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 20 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 1 2 1 2
FastEthernet0/1 2 2 cisco
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
172.16.0.0
Routing Information Sources:
Gateway Distance Last Update
172.16.23.3 120 00:00:25
172.16.12.1 120 00:00:10
Distance: (default is 120)
R2#
Configuration:
R2(config)#router rip
R2(config-router)#timers basic 20 120 120 180
R2(config)#do sh ip proto
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 20 seconds, next due in 3 seconds
Invalid after 120 seconds, hold down 120, flushed after 180
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 1 2 1 2
FastEthernet0/1 2 2 cisco
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
172.16.0.0
Routing Information Sources:
Gateway Distance Last Update
172.16.23.3 120 00:00:10
172.16.12.1 120 00:00:16
Distance: (default is 120)
R2(config)#
RIP Passive Interface Configuration:
We can avoid routing update from all interface or individual interface. So it cant be sent routing update to other interface but receive routing updates from other router.
R4(config)#router rip
R4(config-router)#passive-interface fastEthernet 1/0
or
R4(config)#router rip
R4(config-router)#passive-interface default
R4(config-router)#no passive-interface fastEthernet 1/0
R2 Routing table Before Configure Passive interface fa 1/0 in R4:
R2#show ip route
R 192.168.44.0/24 [120/2] via 172.16.23.3, 00:00:10, FastEthernet0/1
172.16.0.0/24 is subnetted, 4 subnets
R 172.16.34.0 [120/1] via 172.16.23.3, 00:00:10, FastEthernet0/1
C 172.16.23.0 is directly connected, FastEthernet0/1
C 172.16.12.0 is directly connected, FastEthernet0/0
R 172.16.1.0 [120/1] via 172.16.12.1, 00:00:12, FastEthernet0/0
R 192.168.4.0/24 [120/2] via 172.16.23.3, 00:00:10, FastEthernet0/1
//Color Routes are come from R4.
R2 Routing table after configure Passive interface fa 1/0 in R4:
R2#show ip route
172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
R 172.16.34.0/24 [120/1] via 172.16.23.3, 00:00:08, FastEthernet0/1
C 172.16.23.0/24 is directly connected, FastEthernet0/1
C 172.16.12.0/24 is directly connected, FastEthernet0/0
R 172.16.11.1/32 [120/1] via 172.16.12.1, 00:00:00, FastEthernet0/0
R 172.16.1.0/24 [120/1] via 172.16.12.1, 00:00:00, FastEthernet0/0
R2#
Distribute List in RIP
Distribute List can be Implemented only a Single Routing Domain. So lets use Distribute list in RIP.
Routing table of R1 before apply distributed list in R4:
R1#show ip route
R 192.168.44.0/24 [120/3] via 172.16.12.2, 00:00:13, FastEthernet0/0
R 192.168.43.0/24 [120/3] via 172.16.12.2, 00:00:13, FastEthernet0/0 172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
R 172.16.34.0/24 [120/2] via 172.16.12.2, 00:00:13, FastEthernet0/0
R 172.16.23.0/24 [120/1] via 172.16.12.2, 00:00:13, FastEthernet0/0
C 172.16.12.0/24 is directly connected, FastEthernet0/0
C 172.16.11.1/32 is directly connected, Loopback11
R 172.16.23.23/32 [120/3] via 172.16.12.2, 00:00:15, FastEthernet0/0
C 172.16.1.0/24 is directly connected, FastEthernet0/1
R 192.168.4.0/24 [120/3] via 172.16.12.2, 00:00:15, FastEthernet0/0R1#
R3 Routing Log before apply distributed list in R4:
*Mar 1 03:50:37.487: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/1 (172.16.23.3)
*Mar 1 03:50:37.487: RIP: build update entries
*Mar 1 03:50:37.487: 172.16.23.23/32 via 0.0.0.0, metric 2, tag 0
*Mar 1 03:50:37.491: 172.16.34.0/24 via 0.0.0.0, metric 1, tag 0
*Mar 1 03:50:37.491: 192.168.4.0/24 via 0.0.0.0, metric 2, tag 0
*Mar 1 03:50:37.491: 192.168.43.0/24 via 0.0.0.0, metric 2, tag 0*Mar 1 03:50:37.495: 192.168.44.0/24 via 0.0.0.0, metric 2, tag 0
R3#
Configuration: Now Deny 192.168.4.0 and 192.168.43.0 network from R4 by Distributed List.
R4#conf t
R4(config)#access-list 10 deny 192.168.4.0 0.0.0.255
R4(config)#access-list 10 deny 192.168.43.0 0.0.0.255
R4(config)#access-list 10 permit any
R4#conf t
R4(config)#router rip
R4(config-router)#distribute-list 10 out fastEthernet 1/0
Routing table of R1 after Distributed list applied in R4:
R1#show ip route
R 192.168.44.0/24 [120/3] via 172.16.12.2, 00:00:14, FastEthernet0/0
172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
R 172.16.34.0/24 [120/2] via 172.16.12.2, 00:00:14, FastEthernet0/0
R 172.16.23.0/24 [120/1] via 172.16.12.2, 00:00:14, FastEthernet0/0
C 172.16.12.0/24 is directly connected, FastEthernet0/0
C 172.16.11.1/32 is directly connected, Loopback11
R 172.16.23.23/32 [120/3] via 172.16.12.2, 00:00:14, FastEthernet0/0
C 172.16.1.0/24 is directly connected, FastEthernet0/1
R1#
//192.168.4.0 and 192.168.43.0 network denied by Distributed list.
R3 Log:
R3#
*Mar 1 04:34:05.114: RIP: received v2 update from 172.16.34.4 on FastEthernet1/0
*Mar 1 04:34:05.114: 172.16.23.23/32 via 0.0.0.0 in 1 hops
*Mar 1 04:34:05.114: 192.168.44.4/32 via 0.0.0.0 in 1 hops
R3#
//192.168.4.0 and 192.168.43.0 network denied by Distributed list.
Note: Will Be continued with Load Balancing, Redundant link and Redistribution.
No comments:
Post a Comment